<!DOCTYPE html>
<!--[if lt IE 7]> <html class="ie6 ie" lang="en" dir="ltr"> <![endif]-->
<!--[if IE 7]>    <html class="ie7 ie" lang="en" dir="ltr"> <![endif]-->
<!--[if IE 8]>    <html class="ie8 ie" lang="en" dir="ltr"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]> <!--> <html class="not-ie" lang="en" dir="ltr"> <!--<![endif]-->
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="https://chrwradio.ca/sites/all/themes/thirtyfour/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="On Friday Night the (6-0) Western Mustangs hosted the (2-3) Carleton Ravens at TD Stadium for some football under the lights.  The Ravens were eliminated from last year’s playoffs at the hands of the Mustangs in a 51-24 Semi-Finals loss.  Things played out very similarly on this occasion with Western prevailing 51-14 to remain undefeated in the 2017 season.  Here’s the game by the numbers:   " />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<style type='text/css'>body {background: #;}</style> <meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://chrwradio.ca/content/stangs-drop-ravens-numbers" />
<link rel="shortlink" href="https://chrwradio.ca/node/84153" />
<meta property="og:site_name" content="94.9 CHRW / Radio Western" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Stangs Drop Ravens: By The Numbers" />
<meta property="og:url" content="https://chrwradio.ca/content/stangs-drop-ravens-numbers" />
<meta property="og:description" content="On Friday Night the (6-0) Western Mustangs hosted the (2-3) Carleton Ravens at TD Stadium for some football under the lights.  The Ravens were eliminated from last year’s playoffs at the hands of the Mustangs in a 51-24 Semi-Finals loss.  Things played out very similarly on this occasion with Western prevailing 51-14 to remain undefeated in the 2017 season.  Here’s the game by the numbers:   " />
<meta property="og:updated_time" content="2017-10-09T14:37:21-04:00" />
<meta property="og:image" content="Property field_image" />
<meta property="og:image:secure_url" content="https://chrwradio.ca/logo.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@chrwradio" />
<meta name="twitter:url" content="https://chrwradio.ca/content/stangs-drop-ravens-numbers" />
<meta name="twitter:title" content="Stangs Drop Ravens: By The Numbers" />
<meta name="twitter:description" content="On Friday Night the (6-0) Western Mustangs hosted the (2-3) Carleton Ravens at TD Stadium for some football under the lights.  The Ravens were eliminated from last year’s playoffs at the hands of the Mustangs in a 51-24 Semi-Finals loss.  Things played out very similarly on this occasion with Western prevailing 51-14 to remain undefeated in the 2017 season.  Here’s the game by the numbers:   " />
<meta name="twitter:image" content="Property field_image" />
<meta property="article:published_time" content="2017-10-09T14:33:29-04:00" />
<meta property="article:modified_time" content="2017-10-09T14:37:21-04:00" />
	<title>Stangs Drop Ravens: By The Numbers | 94.9 CHRW / Radio Western</title>
	<!-- if home set these metatags -->
<link href='https://fonts.googleapis.com/css?family=Raleway:400,300,200,500,600,900' rel='stylesheet' type='text/css'>
<link href="https://fonts.googleapis.com/css?family=Merriweather:300,400,400i,700,700i,900" rel="stylesheet">
<link href="https://fonts.googleapis.com/css?family=Lato:400,400i,700,700i,900,900i" rel="stylesheet">
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">
	<link type="text/css" rel="stylesheet" href="https://chrwradio.ca/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://chrwradio.ca/sites/default/files/css/css_-2Pn5C1lYdWd6eUBNVZ7t-qFgfQ-n2_N0FZV129Jv3Y.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://chrwradio.ca/sites/default/files/css/css_WTbCGmONmONt8vhxcQtstGYzIX-qw4H3KdyqoXvZQ8g.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://chrwradio.ca/sites/default/files/css/css_PPiVF69vDVQBGfivObdInewejJE46Q7_TeUZWwcRkmI.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://chrwradio.ca/sites/default/files/css/css_VxjtUHPgbjA4Gnab65-hxQQSO5NGy0r3ziVaXeEFbzM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://chrwradio.ca/sites/default/files/css/css_V1PyaC1u0bMjX5gD1jQynBTh_luYmCsYnS71M_AMZ0I.css" media="print" />
	<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.jQuery || document.write("<script src='/sites/all/modules/contrib/jquery_update/replace/jquery/1.10/jquery.min.js'>\x3C/script>")
//--><!]]>
</script>
<script type="text/javascript" src="https://chrwradio.ca/sites/default/files/js/js_3TykeRWpejhD4-J3vdlaNXdULg9xhOZhbsppK0o2bUs.js"></script>
<script type="text/javascript" src="https://chrwradio.ca/sites/all/libraries/mediaelement/build/mediaelement-and-player.min.js?v=2.1.6"></script>
<script type="text/javascript" src="https://chrwradio.ca/sites/default/files/js/js_c9S7L28GiD9hlQGPOAZ-TmAjXzauQOFTS3F37BGHtCQ.js"></script>
<script type="text/javascript" src="https://chrwradio.ca/sites/default/files/js/js_yefrBMhkBSlkUsm2Dh7UxhY0I8_O6YJP8iPdQY2EMG0.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"thirtyfour","theme_token":"ezvVfN_gSFc12GcPLz_ExpnjNt4zHr9WIOFFIA_rfNc","js":{"\/\/ajax.googleapis.com\/ajax\/libs\/jquery\/1.10.2\/jquery.min.js":1,"0":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/libraries\/mediaelement\/build\/mediaelement-and-player.min.js":1,"sites\/all\/modules\/contrib\/simpleads\/simpleads.js":1,"sites\/all\/modules\/contrib\/simpleads\/modules\/simpleads_campaigns\/simpleads_campaigns.js":1,"sites\/all\/modules\/contrib\/mediaelement\/mediaelement.js":1,"sites\/all\/libraries\/audio-player\/audio-player.js":1,"sites\/all\/modules\/contrib\/responsive_menus\/styles\/sidr\/js\/responsive_menus_sidr.js":1,"sites\/all\/libraries\/sidr\/jquery.sidr.min.js":1,"sites\/all\/modules\/contrib\/field_group\/field_group.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.messages.css":1,"sites\/all\/libraries\/mediaelement\/build\/mediaelementplayer.min.css":1,"modules\/book\/book.css":1,"modules\/comment\/comment.css":1,"sites\/all\/modules\/contrib\/date\/date_api\/date.css":1,"sites\/all\/modules\/contrib\/date\/date_popup\/themes\/datepicker.1.7.css":1,"sites\/all\/modules\/contrib\/date\/date_repeat_field\/date_repeat_field.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"modules\/search\/search.css":1,"sites\/all\/modules\/contrib\/simpleads\/simpleads.css":1,"sites\/all\/modules\/contrib\/calendar\/css\/calendar_multiday.css":1,"sites\/all\/modules\/contrib\/views\/css\/views.css":1,"sites\/all\/modules\/contrib\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/contrib\/ctools\/css\/ctools.css":1,"sites\/all\/libraries\/sidr\/stylesheets\/jquery.sidr.dark.css":1,"sites\/all\/modules\/contrib\/field_group\/field_group.css":1,"sites\/all\/themes\/thirtyfour\/lib\/css\/bootstrap.min.css":1,"sites\/all\/themes\/thirtyfour\/lib\/css\/animate.css":1,"sites\/all\/themes\/thirtyfour\/lib\/css\/magnific-popup.css":1,"sites\/all\/themes\/thirtyfour\/lib\/css\/fullcalendar.css":1,"sites\/all\/themes\/thirtyfour\/css\/style.css":1,"sites\/all\/themes\/thirtyfour\/css\/colour.css":1,"sites\/all\/themes\/thirtyfour\/lib\/css\/fullcalendar.print.css":1}},"mediaelementAll":true,"simpleads":{"url":{"ckeditor":"\/simpleads\/dashboard\/ckeditor"},"modulepath":"sites\/all\/modules\/contrib\/simpleads"},"better_exposed_filters":{"views":{"program_views":{"displays":{"block_6":{"filters":[]}}},"tweets":{"displays":{"block":{"filters":[]}}},"post_profile":{"displays":{"user_profile_block":{"filters":[]}}},"related_views":{"displays":{"more_from_author":{"filters":[]},"more_blog_posts":{"filters":[]}}}}},"responsive_menus":[{"selectors":[".bigmenu"],"trigger_txt":"\u2630","side":"right","speed":"200","media_size":"980","displace":"1","renaming":1,"onOpen":"","onClose":"","responsive_menus_style":"sidr"}],"urlIsAjaxTrusted":{"\/content\/stangs-drop-ravens-numbers":true}});
//--><!]]>
</script>
	  
	<!-- Support for HTML5 -->
	<!--[if lt IE 9]>
		<script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->

	<!-- Enable media queries on older browsers -->
	<!--[if lt IE 9]>
		<script src="js/respond.min.js"></script>
	<![endif]-->
<!-- Font-Awesome, Icons Font CSS -->

<!--Favicon-->
<link type="image/ico" href="/sites/all/themes/thirtyfour/favicon.ico" rel="Shortcut Icon">
</head>


<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-84153 node-type-blog" >

	
		<div id="ch-page">
<section id="container">
<!--Header-->
<header> 
  <!-- Navigation Bar -->
  <div id="navigation" class="navigation-bar"> 
      <!--Menu-->
      <nav id="nav" class="navbar navbar-default" role="navigation">
        <div class="container"> 
          <!-- Brand and toggle get grouped for better mobile display -->
          <div class="navbar-header"> 
            <!-- Logo -->
            <div class="logo col-sm-1"> <a href="/" title="Home"> <img class="img-responsive" src="/sites/all/themes/thirtyfour/logo-small.png" alt="Home" /> </a>   </div>
          <div class="nava col-sm-8 animated fadeIn">           
      <div class="region region-menu region-menu">
    <div id="block-menu-block-2" class="block block-menu-block bigmenu">

    <h2>Main menu</h2>
  
  <div class="content">
    <div class="menu-block-wrapper menu-block-2 menu-name-main-menu parent-mlid-0 menu-level-1">
  <ul class="nav navbar-nav"><li class="" class="first leaf menu-mlid-11713"><a href="https://chrwradio.ca" title="Home">Home</a></li>
<li class="" class="leaf has-children menu-mlid-504"><a href="https://chrwradio.ca/stream/" title="Listen to CHRW&#039;s Live Stream" id="listenlive" target="_blank" accesskey="s">Listen Live </a></li>
<li class="" class="leaf has-children menu-mlid-10601"><a href="/programguide" title="Find out what&#039;s is on and when!">Program Guide</a></li>
<li class="" class="leaf has-children menu-mlid-7626"><a href="/get-involved" id="getinvolved" title="Volunteer info">Get Involved!</a></li>
<li class="" class="leaf has-children menu-mlid-7349"><a href="/fundingdrive">Donate</a></li>
<li class="" class="leaf menu-mlid-2737"><a href="/contact-info">Contact Us</a></li>
<li class="" class="last leaf has-children menu-mlid-2734"><a href="/about">About</a></li>
</ul></div>
  </div>
</div>
  </div>
 
            </div>
             <div class="col-sm-3"> 

       <div class="on-air"> 
       <div class="hidden-xs"><ul class="social">                
           <li><a href="http://www.youtube.com/user/chrwradio"><i class="fa fa-youtube"></i></a></li>  
                <li><a href="http://www.facebook.com/chrwradio"><i class="fa fa-facebook"></i></a></li>
                <li><a href="http://twitter.com/chrwradio"><i class="fa fa-twitter"></i></a></li>
                <li><a href="https://instagram.com/chrwradio"><i class="fa fa-instagram"></i></a></li>
                <li><a href="http://pinterest.com/chrwradio"><i class="fa fa-pinterest"></i></a></li>
				 <li> <a href="/user/login">
		<i class="fa fa-sign-in" aria-hidden="true"></i>
				</a>
				</li>
				    <li>  
					<span class="fa fa-search search-toggle" data-toggle="collapse" data-target="#searchTop" aria-expanded="false" aria-controls="searchTop"></span>
	</li>
            </ul>
		            </div>
        
           </div>
                    </div>
          </div>
        </div>
      </nav>
      <!--/Menu--> 
    </div>
    <div class="clear"></div>
</header>

<div class="white-popup mfp-hide" id="showNow"> 
       <div class="region region-top-bar region-top-bar">
    <div id="block-views-program-views-block-6" class="block block-views">

    
  <div class="content">
    <div class="view view-program-views view-id-program_views view-display-id-block_6 view-dom-id-2f55d9056381b2d5f5cfb3847f41ad45">
        
  
  
      <div class="view-content">
        <div>
      
  <div>        <div class="now"><h3>Radio Free London</h3>
<a href="/program/radio-free-london"><img src="https://chrwradio.ca/sites/default/files/styles/300x164/public/images/programs/banner/RFLDJ2_0.png?itok=subSRHKC" width="300" height="164" alt="" /></a>
<h4>NiteBat | <span class="date-display-single">2:00 am</span> | musicmix<h4>
 <p>Specializing in local live recordings from various venues in and around London.</p>
<p>Find temporary archives here:</p>
<p><a href="https://facebook.com/radiofreelondon">https://facebook.com/radiofreelondon</a></p>
  </div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>  </div>
</div>
  </div>
 
</div>
<div class="collapse" id="searchTop">
	  <div class="region region-search region-search">
    <div id="block-search-form" class="block block-search">

    
  <div class="content">
    <form class="search_form" onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/content/stangs-drop-ravens-numbers" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="search-form-block-wrapper">
    <div class="container">
        <div class="col-lg-11 col-md-11 col-sm-11 col-xs-10">
                            <h2 class="element-invisible">Search form</h2>
                        <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." class="form-control form-text" onblur="if (this.value == &#039;&#039;) {this.value = &#039;Search&#039;;}" onfocus="if (this.value == &#039;Search&#039;) {this.value = &#039;&#039;;}" placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="Search" size="15" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-z3uSgSc6_j3-EtpczKx8dsjK-UARUvHy84mh9qOAch4" />
<input type="hidden" name="form_id" value="search_block_form" />
            <div class="clear"></div>
        </div>
        <div class="col-lg-1 col-md-1 col-sm-1 col-xs-2">
            <a class="search-close" href="#"><i class="fa fa-times"></i>
</a>
        </div>
    </div>
</div></div></form>  </div>
</div>
  </div>
	</div>
	    <!--Subnavigation -->
<div id="subnav" class="purple-background">
  <div class="container">
    <div class="col-md-12">  </div>
  </div>
</div>
<!--Subnavigation -->
         
<div id="pageheader">
<div class="container">
  <div class="row">
          <div class="col-sm-12">
                <h2 class="wow fadeInTop">Stangs Drop Ravens: By The Numbers</h2>
              </div>
          </div>
  </div>
</div>
<!--main content -->
<div id="news" class="main-content white-background">
  <div class="container"> 
    <!-- Heading -->
    <div class="row">
            <div class="col-md-8">
                  <div class="doc">  </div>
                                        <!--   stat frontpage conditional  -->
                         <!-- <div class="addthis_sharing_toolbox"></div>  -->
            <div class="region region-content region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    
    <div class="row">
        <div class="col-lg-12">
                                <div class="row fullview">
                        <div class="entry">
                            <div class="meta-full"><span> By <a href="/users/john-urban" title="View user profile." rel="author" class="username">John Urban</a></span><span> in <a href="/sports">sports</a></span><span> on Oct 09, 2017</span> |
                                <ul class="links inline"><li class="blog_usernames_blog first"><a href="/blogs/john-urban" title="Read John Urban&#039;s latest blog entries.">John Urban&#039;s blog</a></li>
<li class="comment_forbidden"></li>
<li class="statistics_counter last"><span>107 reads</span></li>
</ul>                      
<div class="addthis_sharing_toolbox"></div>
                                                       </div>
                                                                        <div class="clearfix"> </div>
                                                                                            <img src="https://chrwradio.ca/sites/default/files/images/blog/Webp.net-resizeimage%20%284%29_2.jpg" alt="" class="img-responsive ">
                                                                                                                                                                    
                                                                    <div class="mp3Play84153">Mustangs RB Alex Taylor<br /><audio src="https://chrwradio.ca/sites/default/files/blog_mp3/Alex%20Taylor.mp3" controls='controls' onplaying="ga('send', 'event', { eventCategory: 'Audio Activity', eventAction: 'playMP3-84153', eventLabel: 'Play Audio'})"></audio>Mustangs WR Brett Ellerman<br /><audio src="https://chrwradio.ca/sites/default/files/blog_mp3/Brett%20Ellerman.mp3" controls='controls' onplaying="ga('send', 'event', { eventCategory: 'Audio Activity', eventAction: 'playMP3-84153', eventLabel: 'Play Audio'})"></audio>Mustangs RB Cedric Joseph<br /><audio src="https://chrwradio.ca/sites/default/files/blog_mp3/Cedric%20Joseph_0.mp3" controls='controls' onplaying="ga('send', 'event', { eventCategory: 'Audio Activity', eventAction: 'playMP3-84153', eventLabel: 'Play Audio'})"></audio>Mustangs K/P Marc Liegghio<br /><audio src="https://chrwradio.ca/sites/default/files/blog_mp3/Marc%20Liegghio_0.mp3" controls='controls' onplaying="ga('send', 'event', { eventCategory: 'Audio Activity', eventAction: 'playMP3-84153', eventLabel: 'Play Audio'})"></audio>Mustangs LB Nick Vanin<br /><audio src="https://chrwradio.ca/sites/default/files/blog_mp3/Nick%20Vanin_0.mp3" controls='controls' onplaying="ga('send', 'event', { eventCategory: 'Audio Activity', eventAction: 'playMP3-84153', eventLabel: 'Play Audio'})"></audio></div>                                                                        

                                                                                                                                                                                                                                                                                                         <p>On Friday Night the (6-0) Western Mustangs hosted the (2-3) Carleton Ravens at TD Stadium for some football under the lights.  The Ravens were eliminated from last year’s playoffs at the hands of the Mustangs in a 51-24 Semi-Finals loss.  Things played out very similarly on this occasion with Western prevailing 51-14 to remain undefeated in the 2017 season.  Here’s the game by the numbers:   </p>
<p><strong>1</strong> – Late in the 4<sup>th</sup> quarter fans at TD Stadium got to see #6 take the helm at pivot.  Connor Wicklum from Ronan, Manitoba dressed as the third-string Quarterback and got his first taste of University Football.  He completed a 7-yard pass to Zach Marcus with under 2 minutes remaining in the game, for a pair of firsts.  First completed pass for Wicklum of his OUA career and first reception for Marcus since the 2015 season.    </p>
<p><strong>1</strong> – Brockville, Ontario native Tanner DeJong had a handful of 1<sup>st</sup> Friday night.  Just like Wicklum for the Mustangs, DeJong for the Ravens got a taste of OUA action in the 4<sup>th</sup> quarter.  Going 4/8 passing for 55 yards and after throwing his first Interception at the Western goal line to Safety Jesse McNair (His 1<sup>st</sup> of 2017), threw for his first Touchdown which was a 12-yard strike to Phil Iloki with 90 seconds left in the game.    <br /><img alt="" src="https://chrwradio.ca/sites/default/files/images/John%20Urban/content/LO4.jpg" /><br /><strong>4</strong> – With 7:08 remaining before halftime, Chris Merchant fired a pass to Alex Taylor for a 10-yard Touchdown to make it 28-0.  This was the 4<sup>th</sup> TD catch of the year for the Winnipeg, Manitoba native.  Interesting for the Running Back who has 742 yards rushing, but only 2 rushing TDs this season, the 4<sup>th</sup> year Senior has found another way to get his majors.  The Mustangs have 10 receiving TDs in 2017 so far, with only half coming from Wide Receivers; Brett Ellerman(2), Malik Besseghieur(2) and Harry McMaster(1).  The other half has come from the backfield with Alex Taylor(4) and Cedric Joseph(1).    </p>
<p><strong>7 </strong>– The Mustangs finished the 2016 regular season with a 7-1 record, thanks to a 38-31 loss to the Ravens in Carleton on September 4<sup>th</sup>.  The win Friday night, gives the purple and white a 7-0 record and a comfortable schedule ahead.  After getting to enjoy Thanksgiving, Western will be thankful for a well deserved bye week, before taking on the Ottawa Gee Gees for Homecoming on Saturday October 21<sup>st</sup> at 1pm from TD Stadium.  The win also locks up a Quarter-Finals bye and home field advantage in the playoffs, setting up the hunt nicely for a Yates Cup.   </p>
<p><strong>8 - </strong>The Ravens defense had only 1 Interception the whole season by a Senior DB Thomas Knapp heading into Friday night.  They managed to obtain two more off the arm of Chris Merchant in the blowout loss.  It was the QB’s second multi-interception game of the season and now has thrown 8 Interceptions, which leads the OUA.  The only game of the year so far Merchant hasn’t thrown a pick was the big 29-13 win at Laurier’s Homecoming, but keep in mind that game also featured his least amount of passing attempts with 16. <br /><img alt="" src="https://chrwradio.ca/sites/default/files/images/John%20Urban/content/LO.jpg" /><br /><strong>8</strong> - Running Back Cedric Joseph grabbed 2 Rushing Touchdowns in the 1<sup>st</sup> half of action, with the first one coming just 2:44 into the game on the Mustangs first drive of the night.  In 4 of the 7 games in 2017, the former Champlain Cougar has had a multi-touchdown showcase.  He now has 8 Rushing Touchdowns on the season which ties him with Johnny Augustine of the Guelph Gryphons to lead the league.  The Junior also ties his Freshman/Sophomore year production, where he grabbed 8 TDs in 15 games.   </p>
<p><strong>14.5</strong> – Middle Linebacker Leon Cenerini for the Carleton Ravens came into the game with 45.5 Total Tackles under his belt, that’s an average of 9.1 Tackles Per Game.  Despite losing big, the 5<sup>th</sup> year Senior from Ottawa, Ontario made sure some Mustangs felt it the next day, leading all players in Total Tackles on the night with 14.5.  As a result of his solid play, he leads the OUA in Tackles Per Game with 10.1, as he continues to punish the opposition.   </p>
<p><strong>23</strong> - It’s coming up to 23 years since November 19<sup>th</sup>, 1994, that’s when the Western Mustangs beat the Saskatchewan Huskies at the SkyDome for their last Vanier Cup Championship.  It takes a lot to go all the way; skill, health, consistency and of course a little bit of luck.  For the best team in the OUA they’ve proven over 7 weeks that they have more than enough skill to be a championship team.  Now with a favorable schedule ahead, can the Mustangs stay healthy and play with the consistency needed to end a long drought.    <br /><img alt="" src="https://chrwradio.ca/sites/default/files/images/John%20Urban/content/LO1.jpg" /><br /><strong>44</strong> – The amount of First Downs Western obtained in the game, compared to 20 by the Ravens.  This was high even by Mustang standards, the team has 227 First Downs so far on the season, giving them an average of 32.4 First Downs Per Game.  What’s even crazier is that they can get First Downs anyway they please, Western leads the OUA with 110 Rushing First Downs and 100 Passing First Downs.</p>
<p><strong>46.1</strong> - The 51 points produced on the Ravens is the 3<sup>rd</sup> time in 2017 the Mustangs offense has put at least 50 points on the board in a game.  With Western dominating the York Lions on the road in Week #1 and the winless Lancers in their barn 59-7 on Week #4 earlier this season.  The team is producing an overbearing 46.1 point per game (the most in the OUA) and it’s just too much for any defense to slow down, let alone stop. </p>
<p><strong>60 </strong>– After Punting the ball 11 times for 371 yards, for an average punt of 33.7 yards 5<sup>th</sup> year Senior Kicker Mike Domagala now has 60 punts this season.  16 of those, he has pins his opponent in their 20.  He has now punted 269 times in his OUA regular season career, totaling 10256 yards, for a career average of 38.1 yards per punt. <br /><img alt="" src="https://chrwradio.ca/sites/default/files/images/John%20Urban/content/LO3.jpg" /><br /><strong>100% - </strong>Call him Mr. Perfect or Money, Sophomore Kicker Marc Liegghio is on fire!  Outscoring the Carleton Ravens 15-14 on his 5 for 5 Field Goal performance (46, 35, 22, 26 and 27).  He has not missed a Field Goal attempt since September 9<sup>th</sup> on the road against the McMaster Marauders, where he still made 2 of 3.  Since then…18 for 18, that includes a record-tying 6 for 6 performance against the Queen’s Gaels and back to back 5 for 5 masterpieces the last two weeks.     </p>
<p><strong>106</strong> - To add to the greatness behind Woodbridge, Ontario’s own Marc Liegghio, is that he has now 106 points for his team through 7 games this season.  To give you an idea of just how great that is, there are 3 teams in the OUA who haven’t managed that amount of point production through 6 games; Toronto Varsity Blues (70), Windsor Lancers (86) and York Lions (102).</p>
 <div class="field-item even"><img src="https://chrwradio.ca/sites/default/files/images/John%20Urban/content/LO4.jpg" width="960" height="540" alt="" /></div><div class="field-item odd"><img src="https://chrwradio.ca/sites/default/files/images/John%20Urban/content/LO.jpg" width="960" height="540" alt="" /></div><div class="field-item even"><img src="https://chrwradio.ca/sites/default/files/images/John%20Urban/content/LO1.jpg" width="960" height="540" alt="" /></div><div class="field-item odd"><img src="https://chrwradio.ca/sites/default/files/images/John%20Urban/content/LO3.jpg" width="960" height="540" alt="" /></div>                                                                                                                                            </div>
                    </div>
                    <!-- end entry -->
                                            <div class="clearfix"></div>
                        <div class="related">
                            <i>
      <div class="view view-post-profile view-id-post_profile view-display-id-user_profile_block view-dom-id-d1b92731bf6caf0d8fc1913c5accdcbd">
        
  
  
      <div class="view-content">
        <div>
      
  <span class="views-field views-field-name">        <span class="field-content">John Urban</span>  </span>  </div>
    </div>
  
  
  
  
  
  
</div></i>
                            <div class="row">
                                <div class="col-md-6">
                                    <div class="view view-related-views view-id-related_views view-display-id-more_from_author view-dom-id-1e10d6286dd29b0f1d4d4bf2b1ad7b53">
            <div class="view-header">
       <h3>More from John Urban</h3>
     </div>
  
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/content/mustangs-perfect-through-week-6">Mustangs Perfect Through Week #6</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/content/mustangs-shine-blackout">Mustangs Shine On Blackout</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/content/stangs-stamp-lancers-numbers">Stangs Stamp Lancers: By The Numbers</a></span>  </div>  </div>
  <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/content/mustangs-beat-marauders-week-3">Mustangs Beat Marauders Week #3</a></span>  </div>  </div>
  <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/content/knights-sign-alec-regula">Knights Sign Alec Regula</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>                                </div>
                                <div class="col-md-6">
                                    <div class="view view-related-views view-id-related_views view-display-id-more_blog_posts view-dom-id-75f8080ad5f6b61e1349ea530d8b41e0">
        
  
  
  
  
  
  
  
  
</div>                                </div>
                            </div>
                        </div>
                        <div id="comments" class="padding-top">
                                                            <div class="clearfix"></div>
                                                        </div>
        </div>
    </div>  </div>
</div>
  </div>
                              <ul class="breadcrumb"><li><a href="/">Home</a></li><li><a href="/blog">Blogs</a></li><li>Stangs Drop Ravens: By The Numbers</li></ul>                              <!--     end frontpage condition --> 
          
                    <div class="clearfix"></div>
        </div>
                <div id="sidebar" class="col-md-4 col-sm-12 col-xs-12">
          
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.4&appId=99213840772";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> 

<!-- Nav tabs -->
<ul class="nav nav-tabs" role="tablist">
  <li role="presentation" class="active"><a href="#tab-facebook" aria-controls="tab-facebook" role="tab" data-toggle="tab">Facebook</a></li>
  <li role="presentation"><a href="#tab-twitter" aria-controls="tab-twitter" role="tab" data-toggle="tab">Twitter</a></li>
</ul>
<!-- Tab panes -->
<div class="tab-content">
  <div role="tabpanel" class="tab-pane fade in active" id="tab-facebook">
    <div class="fb-page" data-href="https://www.facebook.com/chrwradio" data-small-header="false" data-adapt-container-width="true" data-hide-cover="true" data-show-facepile="false" data-show-posts="true">
      <div class="fb-xfbml-parse-ignore">
        <blockquote cite="https://www.facebook.com/chrwradio"><a href="https://www.facebook.com/chrwradio">CHRW 94.9 FM / chrwradio.ca</a></blockquote>
      </div>
    </div>
  </div>
  <div role="tabpanel" class="tab-pane fade" id="tab-twitter">   <div class="region region-tab1 region-tab1">
    <div id="block-block-8" class="block block-block">

    
  <div class="content">
     <p><a class="twitter-timeline" data-widget-id="274508672091160577" height="450" href="https://twitter.com/chrwradio">Tweets by @chrwradio</a> </p>
<script>
<!--//--><![CDATA[// ><!--
!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
//--><!]]>
</script>   </div>
</div>
  </div>
 </div>
</div>
<div class="clearfix"></div>
             <div class="region region-sidebar-right region-sidebar-right">
    <div id="block-simpleads-ad-groups-148009" class="block block-simpleads">

    <h2>Friends of CHRW</h2>
  
  <div class="content">
    <div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-148009', 148009, 1);
  </script>
    <div class="simpleads-148009"></div>

    
</div>
  </div>
</div>
  </div>
 </div>
              </div>
    </div>
  </div>
  </section>
  <!-- /Container -->
   <!-- Footer -->  
   <footer class="black-background">   
  <div class="container">
		    		
			 <div class="row footermenu">
		
		        <ul class="menu"><li class="first expanded"><a href="https://chrwradio.ca/stream/" title="Listen to CHRW&#039;s Live Stream" id="listenlive" target="_blank" accesskey="s">Listen Live </a><ul class="menu"><li class="first leaf"><a href="/content/chrwradio2">CHRWRadio2</a></li>
<li class="leaf"><a href="/programguide" title="Find out what&#039;s is on and when!">Program Guide</a></li>
<li class="leaf"><a href="/posts/featured">Featured Posts</a></li>
<li class="last collapsed"><a href="/allposts">All Posts</a></li>
</ul></li>
<li class="expanded"><a href="/fundingdrive">Donate</a><ul class="menu"><li class="first leaf"><a href="http://www.westernconnect.ca/chrw">Donate via Western</a></li>
<li class="last leaf"><a href="https://chrwfundingdrive.ca" target="_blank">Radio Western Store</a></li>
</ul></li>
<li class="expanded"><a href="/about">About</a><ul class="menu"><li class="first leaf"><a href="/contact-info">Contact Us</a></li>
<li class="leaf"><a href="/about/governance">Governance</a></li>
<li class="last leaf"><a href="/content/history" title="CHRW History">History</a></li>
</ul></li>
<li class="last expanded"><a href="/content/chrw-awards">Volunteer Awards</a><ul class="menu"><li class="first leaf"><a href="/radio-western-music-awards">Radio Western Music Awards</a></li>
<li class="leaf"><a href="/national-provincial-local-awards">National,  Provincial &amp; Local Awards</a></li>
<li class="last leaf"><a href="http://jrlma.ca" title="London&#039;s Only Grassroots Awards Recognizing London Musicians">Jack Richardson London Music Awards</a></li>
</ul></li>
</ul>					   	</div>
		
		 <div class="row">
		 
         <div class="region region-footer-bottom region-footer-bottom">
    <div id="block-block-1" class="block block-block">

    
  <div class="content">
     <div class="marg-top15 text-center"><small>Copyright <a href="https://chrwradio.ca/content/governance">CHRW Radio</a>. Proudly serving the Western University and London communities since 1981.<br />Request Line Call or Text 519-661-3600 | Office 519-661-3601</small></div>
   </div>
</div>
  </div>
    <div class="text-center">  <a href="#container" class="smoothScroll align-right"><i class="fa fa-long-arrow-up"></i>Scroll to top</a></div>
      		
		  </div>

  
  </footer>       
    <!-- /Footer --></div>
<!--Skrollr body-->		
	<!-- Main Scripts-->
  
<!--JS-->
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/jquery-1.11.1.min.js"></script>
<!-- Bootstrap -->
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/bootstrap.min.js"></script>
<!-- WOW On Scroll Animate -->
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/wow.min.js"></script>

<!-- Waypoints Animate - char skills -->
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/waypoints.min.js"></script>
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/jquery.sticky.js"></script>
<!-- Magnific popup-->
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/jquery.magnific-popup.min.js"></script>
<script type="text/javascript" src="/sites/all/themes/thirtyfour/js/app.js"></script>
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/jquery.easing.1.3.js"></script>
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/jquery.matchHeight-min.js"></script>

<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/moment.min.js"></script>
<script type="text/javascript" src="/sites/all/themes/thirtyfour/lib/js/fullcalendar.min.js"></script>
<script type="text/javascript" src="/sites/all/themes/thirtyfour/js/custom.js"></script>
    <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=chrw"></script>



 <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-521696-9', 'auto');
  ga('send', 'pageview');

</script>

</body>
</html>